CentOSでGUIが言うことを聞かない

 2010-04-06
遊休PCにCentOS5.4を入れようとしたらGUIが言うことを聞かなかった。

普通に入れようとすると、GUIインストーラが立ち上がるタイミング付近でLCDが No signal とか言って真っ黒になる。しばらく試したけど面倒になってその場はCUIでインストールしました。なんでだろう。

root% startx

なんてやると、やっぱりXが立ち上がるあたりでLCDが沈黙。。。
/var/log/Xorg.0.logを見てみると、

(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, G35, 965Q, 946GZ,
        965GM, 965GME/GLE, G33, Q35, Q33,
        Mobile Intel® GM45 Express Chipset,
        Intel Integrated Graphics Device, G45/G43, Q45/Q43, G41

という感じでドライバはあたってるっぽい…。
しばらくログを見ていると、

(II) Module ddc: vendor="X.Org Foundation"
        compiled for 7.1.1, module version = 1.0.0
        ABI class: X.Org Video Driver, version 1.0
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/lib/xorg/modules/libi2c.so
(II) Module i2c: vendor="X.Org Foundation"
        compiled for 7.1.1, module version = 1.2.0
        ABI class: X.Org Video Driver, version 1.0
(II) intel(0): Output VGA using monitor section Monitor0
(II) intel(0): I2C bus "CRTDDC_A" initialized.
(II) intel(0): I2C bus "CRTDDC_A" removed.
(II) I2C device "<B8>A<B5>:E-EDID segment register" registered at address 0x60.
(II) I2C device "<B8>A<B5>:ddc2" registered at address 0xA0.

という部分でログが終わっている。DDCモジュール読み込んで、I2CでLCDのジオメトリとか読んだ段階で終わってるのかなー。わからん。。。

モニタとの相性とかかもしれない。。。のかなぁ。。。
調べるのは面倒なので放置中です。vncはできるので、とりあえずコンソールでX上げることはないかなぁと。でもなんかキモチワルイ。

どうすんのこれー?

 

コメント












管理者にだけ表示を許可する
トラックバック
トラックバックURL:
http://wbbwbb.blog83.fc2.com/tb.php/13-29f2a568
≪ トップページへこのページの先頭へ  ≫